WordPress update 1.5.1.2



May 27th, 2005

A security vulnerability has been discovered in WordPress 1.5.1.1 and and update has been released. However, since this is a small issue you might want to fix it manually rather than reload a new version.

Open the file wp-includes/template-functions-category.php in a text editor like WordPad.
On line 103 (or thereabouts if you have made any modifications) find the following code:
function get_the_category_by_ID($cat_ID) {

Below that line add a new line of code:
$cat_ID = (int) $cat_ID;

Save the new file and upload.

Problem fixed!

Well done to the WordPress team for fixing that so quickly!

This entry was posted on Friday, May 27th, 2005 at 18:45 and is filed under Administrative. You can follow any responses to this entry through the RSS 2.0 feed. Responses are currently closed, but you can trackback from your own site.

Comments are closed.